Random Tech Issue

Just in case any tech gurus are reading today: I've been battling a new version of an e-discovery program the Government uses when providing us with wiretap discovery. It's called IPro Tech.

It's using a "new build" and the program won't open on my Windows XP desktop. I get an error that says "run-time error, invalid file format, 20009." [More..]

We aren't provided the full version of the program -- each disk has a self-executing version built in. The disks with the older version work fine. The new disks load on my laptop with Vista, and on the office desktop with XP, but not on my home desktop. The images in the IPro program are "tiffs." I thought it might be conflicting with the scanner, but I have the same scanner attached to both desktops and one works, and one doesn't.

I spent an hour and a half on the phone with the iPro tech people and they can't figure it out. I spent 6 hours yesterday and a $70.00 buying registry cleaners and file fixers in case it was a file association. No go.

I copied one new disk to a thumb drive and put it on my desktop. I opened "explore" on the desktop version and three files came up: Data, Images and "ipro.exe." I changed the "ipro exe" to "ipro1.exe" and pasted in the "ipro.exe" file from a disk with the old version. It worked and I was so excited. But, when I tried to print to pdf, it said a file was missing and I didn't want to fool with my Adobe files, so now I can read but I can't save individual documents. And, there are 20 disks, I don't want to have to do that for each one.

I need to be able to save individual documents on the disk on my hard drive and not have to sift through 20,000 pages every time I want to review them. When I open the image folder, they are there as "tiffs" and if I try to open them, they open in Windows Fax Viewer. When I look to see what file association my computer is using for 'tiffs' and see if I can change it, the only options are Windows Fax Viewer and some program called "Paint."

I know it's a new build because the ipro.exe files on the disk that won't open have a different ipro graphic than the files on the disk that will open, and a slightly different version number.

While the iPro site has some downloads, they are only for those that have the full version of the program loaded on their hard drives. And I don't have it, just the self-executing version that comes on every disk. The Government gave us a "vista fix" because some lawyers were having a problem getting the program to work with Vista, but I'm not having problems with Vista, just with one desktop running XP.

I've done a ton of google searches for "run time errors" and "invalid file format" and nothing helps.

So, any ideas as to what's causing the problem? If I could figure that out, I'm hoping I can get iPro to come up with a solution.

Update: Some pix:

The error message on the new version:


The new version that doesn't work (


The old version that does work (8.60.00):


The disks that work all have this graphic, as opposed to the graphic in the first picture above:


< Halloweeen Open Thread | Halloween Night TV and Open Thread >
  • The Online Magazine with Liberal coverage of crime-related political and injustice news

  • Contribute To TalkLeft

  • Display: Sort:
    Tiffs (none / 0) (#1)
    by TeresaInSnow2 on Sun Oct 31, 2010 at 01:54:40 PM EST
    I assume the CDs are just a mass of documents scanned into Tiffs, and iPro contains a viewer to view them.

    Tiffs are simply uncompressed graphics files.  They can be opened with many different graphics programs...Photoshop, Photoshop elements, many non-Adobe graphics programs, probably free Tiff readers you might encounter on the net, your fax viewer, etc.  They can then be saved as PDFs in some programs (Photoshop being one, Photoshop elements maybe being one).  If I encountered this problem, I might write a batch process in Photoshop and save the Tiffs I want into PDF files.  But you probably don't want to go that route.  If simply reading the Tiffs is an option, you may want to invest in a copy of Photoshop Elements.  It's cheap and a fun program to have anyway, if photo manipulation is interesting to you at all.  You can download a 30-day trial of it from Adobe.  If it helps you, then great.

    The runtime error you're getting sounds like an internal error with the iPro software.  Tech support should have been able to figure out what triggers that.  You might have the wrong version of a PDF converter or something.  I might consider calling on Monday and speaking with a DIFFERENT tech support person.  Often times, that helps.  It also often helps more to talk to the Monday tech support crew than to the Friday afternoon tech support crew....

    thanks for the tiff info (none / 0) (#2)
    by Jeralyn on Sun Oct 31, 2010 at 02:05:27 PM EST
    I have both Photoshop 6.0 and CS-2. But the images are of documents that have been ocr'd and made searchable in iPro and the searchable part is essential to find the needles in the haystack. (The Government won't provide an overall index, the judge refused to make them give us one [I tried]and there are 32 defendants.

    tiffs are generally searchable (none / 0) (#5)
    by Molly Bloom on Sun Oct 31, 2010 at 03:06:03 PM EST
    Open a tiff doc and do controlControl F. It should then tell you it needs to convert the doc. Answer the prompt yes and wait a few minutes. Thereafter you shoud be able to search using control F.

    Also you should be able to highlight and copy text from tiff files into word, if you are using a windows computer with MS office.

    Do know if this helps or not with your current situation, but it may be useful to you down the road, if you are not already aware of this.


    I should add I am using MDI as the viewer (none / 0) (#8)
    by Molly Bloom on Sun Oct 31, 2010 at 03:23:32 PM EST
    you don't want to save docs to mdi files (500kb files become 2mb), but its fine as a viewer and functional for searching and copying test.

    The existence and content of this post (none / 0) (#9)
    by scribe on Sun Oct 31, 2010 at 03:56:15 PM EST
    and the comments tell me that they could easily support a motion for reconsideration of the order denying your prior application for an overall index.

    Just lawyer talk....

    What kind of candy are you handing out for any T-or-T'ers?


    as to the different tech support person (none / 0) (#3)
    by Jeralyn on Sun Oct 31, 2010 at 02:32:39 PM EST
    You may be right on that, but I even logged into some live conference program with him where he got control of my computer so he could check the files  and settings, and he couldn't find anything. I assumed if he could manage that, he could manage their tech stuff. Plus, I'm not a customer of their's since I don't own the program.

    But if I don't solve it by tomorrow, I'm going to call back. Now that I've written this post and put up the graphics, if I ask them to read it, they may have a better idea of what's gone wrong than if I am just trying to explain something I don't understand enough to even describe properly.


    You may have a .dll file conflict (none / 0) (#4)
    by szielinski on Sun Oct 31, 2010 at 03:05:38 PM EST
    There may be a file on you computer -- e.g.  387368.dll or some such thing -- which Ipro needs but which is incompatible with the latest version of Ipro Publish Viewer. If the .tiff files were your problem, they would not open at all in any program. But you can open them in different programs and can open them in an earlier version of Ipro. The fact that the newest self-exe file will work on different Windows versions and on different computers suggests that the no-go computer has software problem -- a .dll incompatibility -- is a likely culprit. These were common in the bad old days, and Microsoft has taken steps to insure that they no longer happen. But...

    Assuming your problem is due to a .dll that's incompatible with your Ipro.exe file, you may be able to fix the problem by updating or uninstalling software. Or, better, Ipro could provide a fix for the incompatibility. So, all is not lost.

    Specifically tell them about the LEAD error 20009. (none / 0) (#6)
    by steviez314 on Sun Oct 31, 2010 at 03:10:19 PM EST
    The Google tells me that the IPRO people used viewer software from Leadtools to view tiff files.

    There might be some DLL file conflict or the Leadtools DLL can't get registered.  I know you say both desktops are XP and have the same scanner, but they might not have the same DLLs to read the scans, and one version might be conflicting with the IPRO dlls.

    This is really just a start for the IPRO people to work on.  There are quite a few google entries on Leadtools error 20009s, but usually developers get them.

    thanks, they are different scanners (none / 0) (#7)
    by Jeralyn on Sun Oct 31, 2010 at 03:16:32 PM EST
    same manufacturer, but the one on my problem desktop is newer.

    I agree with you and szielinski that it sounds like a dll conflict.

    The registry cleaners run dll files and it's not coming up.

    Thanks so much to all of you for responding. I'm off to check leadtools errors after taking a break to go buy candy in case someone comes by trick or treating.


    thanks for the leadtools tip (none / 0) (#10)
    by Jeralyn on Sun Oct 31, 2010 at 04:21:59 PM EST
    I thought lead error meant "most significant" error, as in it was one of many. I had no idea there was a program called leadtools.

    I just found their message board and joined and sent a message to their support person. From answers to other developers, it may be the system 32 folder is missing some dll files.

    I think you need to also add lftif13N.dll and lffax13N.dll. For example if you are loading or saving TIFF image you will need to include LFTIFU.DLL, LFFAXU.DLL and possibly other LF???U.DLL files (depends on the type of TIFF compression you use).

    But that answer was from 2005. Before I go searching for those two dll files and putting them in my system 32 folder, I'm going to see what Ipro says and hope the forum tech person answers me.

    Does that seem to you this is the problem?


    I would have thought that the ipro executable file (none / 0) (#12)
    by steviez314 on Sun Oct 31, 2010 at 05:50:09 PM EST
    would install any dlls you need.

    I would actually try un-installing your scanner software on that PC (as long as you have the original disk and can re-install it later) and see if you can then use ipro.exe.

    Or try using the system config (msconfig) to not have any imaging software start on bootup auomatically.  

    I see those Leadtool files are also in my Program files-hp-digital imaging-bin folder, and they look like later versions than the ones in my system32 folder.


    maybe that's it (none / 0) (#15)
    by Jeralyn on Sun Oct 31, 2010 at 07:30:31 PM EST
    that the scanner or some other imaging program starts automatically on startup. I'm going to go check that right now. At least that would explain why it works on one XP machine and not the other.

    Looks like a known issue (none / 0) (#11)
    by Romberry on Sun Oct 31, 2010 at 04:26:45 PM EST
    The issue you're having has been experienced by others. This Google search will get you into the ballpark.

    Essentially what it boils down to is that you need the correct DLL with the program to decode the particular file format you are asking it to work with. (Not all TIFFs are the same.)

    You can get help (none / 0) (#13)
    by Makarov on Sun Oct 31, 2010 at 06:42:28 PM EST


    They provide telephone support 8am-5pm Mountain Time.

    nm (none / 0) (#14)
    by Makarov on Sun Oct 31, 2010 at 06:43:49 PM EST
    I'm dumb.

    I do second the suggestion you call them back tomorrow and speak to another support person.


    have you tried doing a (none / 0) (#16)
    by cpinva on Mon Nov 01, 2010 at 04:35:43 AM EST
    "save as" to a .pdf file, instead of going directly to print? or, in the alternative, do a copy/paste of the document, to a .pdf or MS Word file, then printing it from there.

    good luck.